SyMenu Forum

SyMenu

 

HomeTroubleshooting & Bug Reports

If you found a bug post here your report.

Trouble with second monitor Messages in this topic - RSS

UksusoFF
UksusoFF
Posts: 7


19/09/2019
UksusoFF
UksusoFF
Posts: 7
Hi!
Can SyMenu shows only on monitor which contains tray icons?
In some cases fullscreen app on second monitor can overlay on SyMenu :/

link
Gianluca
Gianluca
Administrator
Posts: 932


19/09/2019
Gianluca
Gianluca
Administrator
Posts: 932
The problem is not where the menu appears first but where the submenus open subsequently.

It's a problem with every multiple monitors system that I never solved because... I don't have a multiple monitor system to test the problem smile

An effective workaround is to use a keyboard shortcut to open the menu instead of the mouse. This way you can choose where the menu must pop up in your monitor, and, obviously, you don't have to choose the right side of it.
link
UksusoFF
UksusoFF
Posts: 7


19/09/2019
UksusoFF
UksusoFF
Posts: 7
I change this settings:

Some menus now open in main monitor. But not all.
link
Gianluca
Gianluca
Administrator
Posts: 932


19/09/2019
Gianluca
Gianluca
Administrator
Posts: 932
The shortcut key is not intended to force the menu to open in the main monitor, but in the active monitor.

The workaround only helps to avoid the menu breaking across two screens.
link
UksusoFF
UksusoFF
Posts: 7


19/09/2019
UksusoFF
UksusoFF
Posts: 7
If I right understand now menus must be always open to left side?
But it's not so now.
link
Gianluca
Gianluca
Administrator
Posts: 932


19/09/2019
Gianluca
Gianluca
Administrator
Posts: 932
If you use the related shortcut, the menu must be always open on the left side... in the active monitor.
If you open it with the mouse click it opens where the mouse cursor is.
If it doens't work this way, it's a bug.
link
UksusoFF
UksusoFF
Posts: 7


19/09/2019
UksusoFF
UksusoFF
Posts: 7
Seems I not understand how open menu with hotkey.
It's always show on hover. I found Menu → Scroll item right → Never but nothing changed.
link
Gianluca
Gianluca
Administrator
Posts: 932


19/09/2019
Gianluca
Gianluca
Administrator
Posts: 932
Accordingly to your screenshot you haven't changed the default shortcuts.
So you open the menu with CTRL + F1 or the search with SHIFT + CTRL + F1
https://www.ugmfree.it/SyMenuManual.aspx#Advanced_menu_Options_HotKeys


The scrolling option is not related to the menu opening.
link
UksusoFF
UksusoFF
Posts: 7


19/09/2019
UksusoFF
UksusoFF
Posts: 7
Wow. Ctrl+F1 not works for me. Nothing happen.
Changed to Alt+F1 and now see menu on top left angle. This is not so comfortably but workaround if not often use second monitor.

Thanks. Maybe you add settings for open dropdowns always to left/right side in future version? wink
link
Gianluca
Gianluca
Administrator
Posts: 932


19/09/2019
Gianluca
Gianluca
Administrator
Posts: 932
My intention is to solve the dual monitor problem instead. This way the choose for the right opening direction is on the program.
The problem with the CTRL + F1 is probably due to a conflict with another program that uses the same shortcut.
link
UksusoFF
UksusoFF
Posts: 7


19/09/2019
UksusoFF
UksusoFF
Posts: 7
Gianluca wrote:
My intention is to solve the dual monitor problem instead. This way the choose for the right opening direction is on the program.

This will be great smile If you need testing please send me beta.
link
Gianluca
Gianluca
Administrator
Posts: 932


19/09/2019
Gianluca
Gianluca
Administrator
Posts: 932
UksusoFF wrote:
This will be great smile If you need testing please send me beta.

Thanks for you kind offer but I have to find a second monitor to test it with the code.
link



UGMFree.NET ©2002-2019
By Gianluca Negrelli - Contact me